+38 (067) 901-63-22

Корзина

0 товара(ов) на сумму
0 грн.

Генерация изображения штрих-кода в 1С при работе в Linux

Написали маленькую функцию, которая генерирует штрих-код в Linux и получает его в 1С.
Функция ШтрихКодПоказать(Штрихкод, Стандарт="128") Если Штрихкод="" Тогда // Если не указали штрих-код, тогда выводим в CODE 128 Предупреждение("Не указан штрих-код!",5); Иначе Файл="/tmp/"+Штрихкод; ЗапуститьПриложение("barcode -p letter -g 200x100 -u mm -b "+Штрихкод+" -e 128 -o "+Файл+".ps | convert -density 150 -trim "+Файл+".ps "+Файл+".png"); Файл=Файл+".png"; КонецЕсли; Возврат Файл; КонецФункции Процедура ОбработкаШтрихкодаНажатие(Элемент) S=ШтрихКодПоказать("58765", "ean13"); Предупреждение("На всякий случай ждем 1 секунду", 1); ЗапуститьПриложение(S); КонецПроцедуры

Параметры функции Штрих-код:

Штрих-код - буквенно-цифровое значение штрих-кода.
Стандарт - стандарт штрих-кода. Предусмотрены такие значения данного параметра, отвечающие за соответствующий стандарт:

 "ean", "ean13", "ean-13", "ean8", "ean-8" "upc", "upc-a", "upc-e" "isbn" "39", "code39" "128c", "code128c" "128b", "code128b" "128", "code128" "128raw" "i25", "interleaved 2 of 5" "cbr", "codabar" "msi" "pls", "plessey" "code93", "93"